Issue with iOS app download on Apple App Store
Incident Report for ABC Trainerize
Resolved
Hi everyone, we are happy to announce that the recent issue with being unable to download the ABC Trainerize app from the Apple App Store has been successfully resolved and the app is once again available for download on the Apple App Store.

For those with Pro custom branded app icons, your clients will temporarily see the new ABC Trainerize icon on their iOS app. Our team will also continue to prioritize investigating a new way to move forward with all the custom branded app icons without posing any risk to the app overall when it comes to being downloaded from the Apple App Store and to ensure that your coaching business experiences as little disruption as possible.

Thanks for your patience!
ABC Trainerize
Posted Aug 26, 2023 - 15:42 PDT
Update
Latest Update on the Apple App Store download issue.

While we've been working with the team at Apple to sort this glitch from their side, we don’t anticipate their team to provide the necessary fix fast enough. We know how critical it is to have your app available for download to be able to coach your clients, which is why we’re falling on our Plan B of submitting an alternate app build to Apple to accelerate a solution.

Plan B: Alternate App Build: We're currently in the process of resubmitting the app to Apple with a new build that addresses the custom branded app icons issue. However, this option does require us to temporarily remove all the existing Pro custom branded app icons from this build.

We understand that this solution isn’t ideal for those who have a Pro CBA, and we will do our best to come up with a solution as soon as possible, but for the time being, we believe this is the best option. This option ensures that the app will be available for everyone to download and use, while also allowing everyone to update to the latest ABC Trainerize version of the app that contains a lot of fixes and improvements.

⏭️ What’s next:

Once we’ve submitted our iOS build to Apple for approval, the timeframe for when it’ll be approved is entirely up to Apple’s process. Meaning, we can’t guarantee how long it’ll take for it to be approved and when the fix will be made.

In the background, our team will prioritize investigating a new way to move forward with all the custom app icons without posing any risk to the app overall when it comes to being downloaded from the Apple App Store and to ensure that your coaching business experiences as little disruption as possible.

We want to extend our heartfelt apologies for any inconveniences this might have caused for you and your clients. Thank you for your patience and understanding as we solve this issue with Apple.
Posted Aug 25, 2023 - 14:27 PDT
Update
Update on the Apple App Store download issue.

We are working with the Apple team to tackle the issue head-on. It's at the top of our priority list, as we fully understand the impact of the issue and the importance of the fixes for your coaching business.

Possible Cause of Issue:
Upon further investigation from our them, the issue seems to be connected with the numerous custom branded app icons that were included in the latest Apple app store build. While we're working with Apple to sort this out, we've outlined two potential pathways to accelerate a solution:

Waiting for Apple's Magic: We're currently in discussions with Apple to solve the glitch from their side. If we receive Apple’s approval in the next hour or two, the new app will be available for everyone with all the latest fixes, including the custom branded app icons.

Plan B: Alternate App Build: As a safeguard, if Apple isn’t able to solve on their end, we've also started exploring the option of resubmitting the app with a new build that addresses the custom branded app icons issue. This would ensure everyone will get access the latest fixes and the ability to download and use the ABC Trainerize version of the app. However, this option does require us to temporarily remove all existing Pro custom branded app icons.

We'll share updates as they become available. We appreciate your patience and understanding as we work towards a fix to this situation.
Posted Aug 25, 2023 - 11:11 PDT
Identified
You and your clients may come across an issue with downloading the latest version of the ABC Trainerize app (v7.90.0) on the Apple App Store, as no download occurs. This is currently impacting the Trainerize iOS app and Pro CBA iOS apps, which means you and your clients are unable to download, update, and reinstall the app. Clients can continue to use the current version of the app that they have, and update the app when this issue is resolved to get access to the latest app updates.

We are aware of this issue and are working on a fix with the Apple team to resolve this as soon as possible. Stay tuned for updates.
Posted Aug 24, 2023 - 14:21 PDT