Past Exercise Stats Temporarily Disabled - Mobile

Incident Report for ABC Trainerize

Resolved

This issue has been resolved, and platform performance has remained stable following our fix. We will continue to monitor to ensure ongoing stability.
Past Exercise Stats functionality has been re-enabled in the mobile app and is now available for Trainerize mobile users.

Thank you for your patience and understanding while our team worked to restore full functionality.
Posted Jun 18, 2026 - 22:11 PDT

Monitoring

We have implemented a fix for an issue impacting ABC Trainerize and are currently monitoring platform performance to ensure continued stability.

As part of this process, the Past Exercise Stats functionality has been temporarily disabled in-app while our team continues to validate platform stability.

We appreciate your patience and will provide another update as soon as more information becomes available.
Posted Jun 18, 2026 - 10:07 PDT
This incident affected: trainerize mobile users.