Fixed - Workouts are disappearing from the Client's Calendar after being subscribed to the Master Program
Incident Report for ABC Trainerize
Resolved
Hi everyone, thank you for your patience. The bug is now resolved.
Our teams will continue to monitor, please let us know if you experience any other issues. Thank you!
Posted Apr 17, 2023 - 19:26 PDT
Update
We have restored access to the web and mobile apps and we are still working on the calendar fix, we hope to be ready with another update in a few minutes. We are sorry for the inconvenience. Thank you for your patience.
Posted Apr 17, 2023 - 18:34 PDT
Update
Hi everyone! We are currently experiencing an outage as we are working on releasing a fix for a bug related to Client’s Calendars after being subscribed to the Master Programs.
We hope to restore access to the web and mobile apps as soon as possible and we will update as soon as possible.
We are sorry for the inconvenience. Thank you for your patience.

Visit and subscribe to our status page: https://status.trainerize.com/ for the latest status updates.
Posted Apr 17, 2023 - 18:22 PDT
Monitoring
Workouts are disappearing from the Client's Calendar after being subscribed to the Master Program:
The issue is happening if the new client is subscribed to the Master Program. The program shows up under the Training Phase Tab, but not in the Calendar. The content will disappear for any new program assigned to a client.

Our team has investigated and worked to:
- Apply a temporary fix and patch asap. This should resolve the issue temporarily for customers and clients currently experiencing this.
-Release a full fix at the end of today. This should resolve the issue and prevent this from occurring again for customers and clients.
Posted Apr 17, 2023 - 11:03 PDT