MyFitnessPal integration is not syncing meal diary data
Incident Report for ABC Trainerize
Resolved
Hi everyone, we've resolved the issue regarding the MyFitnessPal meal diary data sync and have an alternative solution if you’re still having trouble viewing clients’ meal diary details.

In our latest efforts, we've fine-tuned the backend of our MyFitnessPal integration so that you can once again view those key meal diary details right from the app. Your clients will need to disconnect and reconnect their MyFitnessPal account. However, we do have to acknowledge that this may be a temporary solution due to ongoing data limitations beyond our control, and some of you may still face difficulties accessing meal details.

🆕 That’s why, in addition to these upgrades, our team has worked to develop an alternative solution to help you achieve the same goal: quickly viewing your clients' meal details from MyFitnessPal.

If you are not able to see the meal diary in app, you can now also access your clients' meal diary details for the day through a direct link that takes you to their public profile on MyFitnessPal. This direct link is now available both on our web and mobile apps and it makes it super easy to access the information. Check out this help article for step-by-step instructions: https://help.trainerize.com/hc/en-us/articles/20288270919572

Thank you for your patience as we worked on resolving this issue. If you are still having trouble, please do not hesitate to contact our team at https://help.trainerize.com/hc/en-us/requests/new for more help.

Check out the link below for more details 👇
https://resources.trainerize.com/myfitnesspal-integration-meal-diary-sync-issue-email-2
Posted Jan 15, 2024 - 15:39 PST
Identified
Here's the latest update regarding the MyFitnessPal meal diary data sync issue. Learn more about the situation, our response, and the available options for you in the below link 👇

https://resources.trainerize.com/myfitnesspal-integration-meal-diary-sync-issue

We understand the significance of this integration sync in your coaching service. We want to reiterate our commitment to finding a solution that provides the same result of allowing you to view meal details from MyFitnessPal. We'll share an update on our progress on this shortly. We appreciate your patience and understanding as we navigate this situation.
Posted Oct 26, 2023 - 14:28 PDT
Update
Hi everyone, here’s the latest update on the reports that we have been receiving regarding the MyFitnessPal integration not syncing meal data for some clients.

Those experiencing this sync issue are currently unable to see client’s meal details that are normally pulled from MyFitnesPal. This issue cannot be corrected by having client’s manually sync meal diary data from their accounts.

Please note this issue does not impact the sync of client’s tracked calorie and macro data, nor does it affect ABC Trainerize in-app meal tracking. So your clients won’t experience any disruption as they work to hit their daily nutrition goals.

We will continue to investigate and work toward a solution– more information will be provided as our investigation progresses. Thank you!
Posted Oct 16, 2023 - 16:52 PDT
Investigating
Hi everyone, we have been receiving reports that the MyFitnessPal integration is not syncing meal data for some clients. This sync issue impacts meal details only, and not calorie or macro data.


If your client’s complete nutrion data is not syncing, please have them follow these steps and sync the meal information manually. They can do this by going in the app and hitting the More tab (3 dots on the bottom right corner of the app) > Selecting MyFitnessPal > Selecting Ensure Diary Syncing is enabled -> then lastly, hitting Sync Now.

For more troubleshooting instructions, please see this MyFitnessPal Troubleshooting Article

We will continue to monitor and investigate the sync issue on our end and update once we have more information. Thank you!
Posted Oct 10, 2023 - 16:52 PDT