Hi everyone, we are still investigating reports of latency on both our web and mobile apps. We will continue to closely monitor performance to ensure everything is running smoothly.
Thank you for your patience.
Posted Mar 02, 2026 - 10:58 PST
Monitoring
Hi everyone, our team has fully restored services across both our web and mobile platforms.
We will continue to closely monitor performance to ensure everything is running smoothly.
Thank you for your patience, and we sincerely apologize for any inconvenience this may have caused you and your clients.
Posted Mar 02, 2026 - 10:51 PST
Investigating
Hi everyone, we're aware of an issue causing inability to login to the ABC Trainerize platform from both the web and mobile apps. Our team is actively investigating and will provide an update shortly. We apologize for this inconvenience. Thank you for your patience.
Posted Mar 02, 2026 - 08:24 PST
This incident affected: trainerize.com, trainerize web users, trainerize mobile users, and API.